Data Manipulation with Microsoft Excel 2002

1.1    About Spreadsheets

Spreadsheets are effectively flat-file databases, i.e. databases that contain a single table. Unlike relational databases, they cannot handle one to many relationships. For instance if information were required on a series of patient attendances at a clinic, this would be modelled in Microsoft Access by storing data about patients in one table and data about clinic visits in another. 

If, however, the situation to be modelled is simple, then Excel will be a useful tool for storing and manipulating the data.

1.2    Aim of this Document

This document gives a set of exercises in manipulating data using Excel, and these exercises should be appropriate to anyone wanting to record and summarise data.

It is assumed that you already know how to open, close, save and print an Excel spreadsheet and that you know how to enter and edit data.  If you are new to Excel it will be necessary for you to read and work through the following document before attempting these exercises:

Filtering Data

Filters are used to select only records (rows) that meet specific criteria. (In database terminology, filters are known as queries.)  There are three different tools for finding and filtering records in Excel:

· Data Form 

· Autofilter 

· Advanced Filter 

In this document the first two of these methods will be described. Information about Advanced Filtering can be obtained from the Excel Help system.

2.1 Data Form

A data form is a dialog box that provides a convenient way to enter, display or select a complete row of information (record). Before a data form can be used to add a record the sheet must have labels at the top of each column. Microsoft Excel uses these labels to create fields on the form. The database should be surrounded by blank cells, although it is acceptable to have the top and left edges touch the top and left edges of the worksheet.

The data form has two purposes:

· It can be used for data entry 

· New records can be added. 

· Existing records can be modified. (The changes can be undone using the RESTORE button as long as the record is current.) 

· The current record can be deleted. (Note, however, that once a record has been deleted, it cannot be restored and it will be necessary to re-enter the data.) 

· It can be used to carry out a search for records that match the specification. 

The advantage of using a data form is its ease of use. It makes entering search criteria simpler.

The disadvantages are that data forms can display a maximum of 32 fields at a time, and the complexity of criteria that can be written for record selection is quite limited.

Task 1: Creating a Data Form

Activity 1.1 

Run Microsoft Excel by selecting Start > Programs > Microsoft Office XP > Excel
Activity 1.2 

Click File > Open > tut130.xls (the file that you saved earlier). This file contains three worksheets. Ensure that the worksheet DataForm is selected. 
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Figure 1 Worksheet Names

Activity 1.3 

Click somewhere in the data region (A1:F2156) and select Data > Form from the menu.
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Figure 2 The Data Menu

Activity 1.4 

Click on the Criteria button and then type Tofu in the Product Name field. Click the Find Next button to move to the first record for the product Tofu. Move forwards through the matching records by repeatedly using the Find Next button. The last record will be for Order ID 10333
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Figure 3 Data Form Dialog Box

Activity 1.5 

Click the Criteria button again to return to the earlier dialog box, and then select Clear to remove the word Tofu from the form. 
Experiment with other searches. Note that more than one criterion can be used. 
Note also that if a search is unsuccessful - i.e. no records match the search criteria, the record displayed will be the one that satisfied the previous search criteria. Care is therefore needed when using this facility.

Activity 1.6 

Use the New button to move to a blank record, and add new details for customer ZZZ. (If the New button is greyed out, click the Form button to make it available.) When you have completed the entry, click New again. Close the form and observe that your new record has appeared at the end of your worksheet.

Activity 1.7 

elect a cell somewhere inside the database and click Data > Form again. Use the scrollbars to move to the last record entered (Customer ZZZ). Click the <Delete> key to remove it.

Auto filter

Auto filter can be turned on simply by selecting a cell in the database and then choosing Data > Filter > Auto filter from the menu. (Note that if a range of cells is selected, Auto filter will filter just the selected cells rather than the whole of the database.) To remove the filters, select Data > Filter > Auto filter again.

Using Auto filter five choices are possible:

· All - Show all records 

· Top 10 - Display the top (or bottom) 10 records 

· Custom - Displays the Custom Filter dialog box 

· Blanks - Display only records which have a blank in that field 

· Non-blanks - Display all records with any entry in that field. 

Task 2 Filtering 

Activity 2.1 

Click on the worksheet named Filter.
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Figure 4 Worksheet Names

Activity 2.2

Select a cell in the database and switch on Autofilter. The header row will now have an arrow next to each label.
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Figure 5 Autofilter On


Activity 2.3 

Click on the arrow at the top of the Customer ID field and select ANATR from the list to display only those records for that customer.
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Figure 6 Autofilter on Customer ID Field 

Activity 2.4 

Observe the result of the Autofilter At the left of the screen, the row numbers of the selected records are displayed.
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Figure 7 Filtered Records (Customer ID )

Activity 2.5     

Now select Order 10625 to filter this subset further. 
[image: image8.jpg]1
14
15
15
17
18
19
Fi]
2
2
23

A

B =

D E

F

Sustome | Order! Product N [ Csant |Gty Per L+ | Ui <

ANAT (3D Tofu
AnaT|{Te10-) | Teatime Choct
ANAT {6356 Camembert Pi
ANaTlioes Kanbu

ANAT Gudbrandsdal
ANATAZZ s Mascamone F
ANATR 10308 Outback Lage
ANATR 10925 Mozzarella di
ANATR 10625 Singaporean -
ANATR | 10925 Queso Cabralt

540100 g pkgs
7110 boxes x 12 pi
10 15 - 300 g rounds
102 kg box

1110 kg pkg
1024 - 200 g pkys.
524355 mi bottle
1024 - 200 g pkys.
5321 kg pkgs.
2.1 kg pke.

2325

$9.20
$34.00

$6.00
$36.00
$32.00
$15.00
$34.80
$14.00
$21.00






Figure 8   Filter on Order
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Figure 9   Filtered Records (Customer ID and Order)

Activity 2.6      

Now restore all the records by clicking on the Customer ID arrow and selecting Show All, and then by clicking on the Order ID record and selecting Show All. It may be necessary to use the scroll bars to move to the first option. 
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Figure 10   Show All Records

Activity 2.7      

More complex criteria can be set using the Custom Filter option. To select records whose Unit Price is between $80 and $90 inclusive, click the arrow next to Unit Price and select Custom. Complete the dialog box shown below: 
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Figure 11   Custom Autofilter Dialog Box

Activity 2.8     

It is also possible to filter text fields. To select all records for customers whose Customer ID begins with B or C, complete the Autofilter dialog box as shown. Note that the filter is not case sensitive, so there is no need to specify upper case.
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Figure 12   Custom Filter on Text Field

Activity 2.9      

Restore all records by clicking on the arrow next to Customer ID  and choosing ALL.

Activity 2.10   

Find a blank entry in the ProductName field by clicking on the appropriate arrow and selecting BLANKS. It will be necessary to scroll to the bottom of the options to find this. The following record should be returned: 
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Figure 13   Retrieved record with Blank Cell

Activity 2.11    

Experiment with the other options on the custom menu. Note that to be selected, AND selections must meet both criteria, whereas OR selections must meet at least one criterion.

Activity 2.12    

When you have finished, remove the filters by selecting Data > Filter > AutoFilter. The complete dataset will now be restored.

Sorting Data

There are some quirks to be aware of when using Excel's sorting facilities.

· If there is a blank line in the dataset, Excel will assume that the first blank line marks the end of the range, and it will only sort the data up to that position. 

· If you have already named a range (by highlighting all the data, selecting Insert > Name > Define and giving the database a name) that contains one or more blank rows, when Excel sorts the data it will move any blank rows to the end. 

In addition to providing sorted information for reports, it is necessary to sort a file (often on more than one field) in order to use Excel's Subtotal feature 

3.1    Default sort orders

In an ascending sort, Microsoft Excel uses the following order. (In a descending sort, this sort order is reversed except for blank cells, which are always placed last.)

· Numbers:   Numbers are sorted from the smallest negative number to the largest positive number. 

· Alphanumeric sort:   When alphanumeric text is sorted, Excel sorts from left to right, character by character. For example, if a cell contains the text "A100," Excel places the cell after a cell that contains the entry "A1" and before a cell that contains the entry "A11." 

Text and text that includes numbers are sorted in the following order:

0 1 2 3 4 5 6 7 8 9 (space) ! " # $ % & ( ) * , . > : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 

Apostrophes (') and hyphens (-) are ignored, with one exception: if two text strings are the same except for a hyphen, the text with the hyphen is sorted last.

Additional options are available: if for example a field contains months of the year, or days of the week, the data can be sorted by month or day. These lists are already known to Excel, but user-defined lists may be added if required.  (Use Tools > Options > Custom Lists to define a new list).

3.2           Restoring the Original Order.

It is often desirable to return to the original sort order, after reorganizing the record sequence. 

This can be carried out simply, by inserting a column at the beginning of the data, and inserting the numbers 1,2,3...

This will be demonstrated at the beginning of the next task.

Task 3 Sorting Data into Groups

Activity 3.1 

For this task, use the sheet named Subtotals.

First, create a key field so that the original sort order can be restored. Click in cell A1 and select Insert > Column. 
Type the word KEY in the new cell A1. 
Type 1 in A2 and 2 in A3, then press Return to confirm the entry. 

Highlight the cells A2 and A3, and point the mouse at the bottom right-hand side of cell A3 (notice that there is a black rectangle in this position). 

When the cursor shape changes to a crosshair, double click the mouse, and the series will be continued to the end of the dataset.
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Figure 14 Insertion of a Key Field

Activity 3.2 

A simple sort on a single column can be carried out using the Ascending and Descending tools on the toolbar. 
Try sorting on several fields. When you have finished, sort the KEY column (column A) in ascending order. 
Note that a sort can be undone (immediately afterwards) by selecting Edit > Undo.
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Figure 15 Sort Ascending /Descending Tools 

Activity 3.3 

Select Data > Sort, and complete the dialog box as shown to sort first on Country, then on City and finally on TotalValue. 
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Figure 16 Sort Dialog Box

Note that the Options button on this dialog box would allow sorting by month or day.

Activity 3.4 

Restore the original sort order by sorting on the Key column. 
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Figure 17 Restore Original Order

Subtotals

Although subtotals can be created manually using the subtotal function, a facility exists to perform this process automatically. In addition to calculating a sum, there are options to calculate, for instance, a count, average, maximum value and minimum value for the specified fields.

Before using the Subtotal command, it is necessary to sort the file into the correct order.

An outline will be produced for each subtotal, which will allow the detailed information to be hidden. This technique is useful for creating charts that contain summary information. 

Task 4 Simple Subtotal

The Subtotals worksheet should be used for this task 

Activity 4.1 

Sort the file in ascending order of Customer ID using the technique covered in Task 3. From the menu select Data > Subtotals, complete the dialog box as shown below and click OK. 
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Figure 18 The Subtotal Dialog Box


Activity 4.2 

Excel has created an outline, shown at the left-hand side of Figure 19 below. Click on each of the minus signs to remove the detail level. 
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Figure 19 Subtotals with Outline

Activity 4.3 

Hide columns C to H by highlighting them and selecting Format > Columns > Hide from the menu. A summary of the Total value of each customer's order is now displayed. 
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Figure 20 Summary of Total Order Value for Customers

Activity 4.4 

Highlight the cells shown below. (To highlight a range of non-contiguous cells, highlight the first column, hold down the Control Key and then highlight the next column.) Click on the Chart Icon on the toolbar to activate the wizard and create a chart. 
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Figure 21 Highlight the Summary Data

Activity 4.5 

Click on the minus sign corresponding to Level 1 to display only the Grand Total. 
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Figure 22 Grand Total of Order Values

Activity 4.6 

Ensure that one of the cells in the database is selected. Remove all totals by selecting Data > Subtotals and then clicking Remove All. 
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Figure 23 Subtotal Dialog Box

Activity 4.7 

Sort the data using the field Key to restore the file to its original state. Highlight columns B and I and select Format > Column > Unhide to view the complete dataset.

Task 5 Complex Subtotals

The next exercise will illustrate a more complex summary, using more than one field in the database. This exercise will also use the Subtotals worksheet.

Activity 5.1 

First sort (ascending) the data by Country and then by Contact Name using Data > Sort 
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Figure 24 Sort Dialog Box Activity 5.2

First use Data > Subtotals to create a subtotal of Total Value on the Country field, using an average function. Click OK 
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Figure 25 Subtotal Dialog Box 

Activity 5.3

Use Data > Subtotals to see the Subtotal dialog box again. This time uncheck the Replace Current Subtotals check box, and specify the average function again, at each change in Contact Name. Click OK 
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Figure 26 Subtotal Dialog Box Showing Second Specification

Activity 5.4 

Highlight columns A to G and choose Format > Column > Hide from the menu. Highlight columns I to K and choose Format > Column > Hide from the menu.

Activity 5.5 

Click on the minus signs for Level 3 to remove the details of individual transactions and view the average for each contact only. (When you do this the minus signs will change to plus signs.) 
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Figure 27 Level 3 Outline Collapsed

Activity 5.6

Click on the minus signs for Level 2 to remove the details of individual contacts and show only the average for each contact. 
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Figure 28 Level 2 Outline Collapsed

Activity 5.7 

Click on the minus sign for Level 1 to remove the details of individual countries and show only the overall average.

Activity 5.8 

Remove all subtotals. (Select Data > Subtotals and click on Remove All). Click in the cell above the row number and to the left of the column letter. The whole of the spreadsheet will be highlighted.  
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Click Format > Column /Unhide from the menu to view all the data. 
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Figure 30 Columns H - L Highlighted

Activity 5.9 

Sort the file on the KEY field to restore the original order. 

Task 6 Finishing Excel

You should always quit any computer program when you have finished your session. Never switch off the computer without closing down Windows. Do not leave a computer whilst you are still logged on to it as others may use your account and could damage your files.

Activity 5.1 

Select the File > Exit. Excel will prompt you to save your document before it lets you quit. Click to save the changes, to quit without saving the changes, or to return to the spreadsheet. 
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Figure 31 Quit dialog Box

